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CAPTURING A SCREEN SHOT FROM THE CFX-9850GB PLUS
To capture a screen dump you will need:
•
•
•

a calculator (9850 GB PLUS in this case)
an FA-123 cable that comes with the FA-123 kit.
a computer (MAC or IBM compatible) with the FA-123 software installed. To
install the software, follow the instructions that come with it. It is available free
from the net. Simply double clicking on the installer (Setup.exe) and following
the instructions will see you successful.

A note for users with USB (only) equipped machines.
The appropriate cable for data transfer uses a standard serial (called a COM port on an
IBM compatible machine). Users with only USB equipped machines require a USB to
serial adaptor.
Tired and proven adaptors available in Australia are:
• New Motion mini-iDoc
http://www.newmotiontech.com/new/products/mac/miniidock.htm , this is the
only adaptor that has been proven to function faultlessly. This is available at
good MacIntosh resellers. Do not buy any other kind of adapter - see below.
•

Dolphin USB 1.1 to Serial Adaptor for a Windows compatible machine (USB
9013) http://www.dolphinfast.com/products/9103. This is available at Dick
Smith stores. Do not buy any other kind of adapter - see below.

Please note that Belkin and Keyspan adapters have been tested and found not to work
for this application.
To capture a screen shot do the following:
Connecting the calculator to the computer
Connect the calculator to the computer. If you have a IBM-Compatible, put the 9 pin
D type plug into a COM port on the back of the computer. If you have a Mac, use the
9 pin D type to serial port connector that comes with the FA-123 kit and plug it into
the serial (or printer port) on the MAC. Plug the other end of the cable (the ear-phone
type jack) into the port on the bottom of the calculator.
Setting up the calculator
From the calculator MAIN MENU choose LINK (D). This takes you to the
communication mode. From here you need to ensure that the Image Set is set to
something rather than Off. I have it set on Monochrome. (You can’t get a screen
shot of it set to Off).
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To do this use IMGE (F6) and then select either
Monochrome (F2) or Color (F3). The
message [F-D:Copy] tell you that the fraction to
decimal key is the key that sends the screen shot to
the computer.
The calculator is now set up to send screen shots to the computer.
Setting up the computer - IBM Compatible
Start the program called FA-123 (it will be in the C:\Fa-123 directory). You should
put a short-cut on the desktop.
Go to the Tool menu and and select the fx-7400/CFX 9850 series.
Then go to the Link menu and choose Communications…
Select the COM port that you have attached the cable to, it is likely the machine will
have only one COM port, so choose COM1 and click OK.
Now go to Link again and choose Screen Capture. A progress box should appear.
Now go to the calculator and get to the screen you want to capture. You need not
rush, the computer will wait until you are ready. Once you have the screen on the
calculator press the F ↔ D key and the progress meter on the computer screen will
start to progress and then you will have the screen shot in the computer.
To take further screen shots simply go back to Link again and choose Screen
Capture, get to the screen you want to capture on the calculator and then press the
F ↔ D key.
Setting up the computer - MacIntosh
Start the program called FA-123 (it will be in whatever folder you created for it. It is
nice to make an Alias and put this in your Apple Menu for quick access).
Go to the Link menu, select Model Type and then select fx-7400/CFX 9850 series.
Then go to the Link menu again and choose Communications….
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Choose the port to which you have connected the cable (usually serial or printer port
on an older MAC) from the Current Port box, ensure all other settings are as shown
and click OK.
Now go to Link again and choose Screen Capture. A progress box should appear.
Now go to the calculator and get to the screen you want to capture. You need not
rush, the computer will wait until you are ready. Once you have the screen on the
calculator press the F ↔ D key and the progress meter on the computer screen will
start to progress and then you will have the screen shot in the computer.
To take further screen shots simply go back to Link again and choose Screen
Capture, get to the screen you want to capture on the calculator and then press the
F ↔ D key.
Placing a screen dump into MS WORD.
Leave the FA-123 program on the computer running. Start MS Word from the Start
Menu.
Type whatever text you require. For this exercise type a short paragraph that describes
the screen shot you have just taken.
Place the cursor at the start of the paragraph. Return to the FA-123 program (by using
the option on the task bar of Windows at the bottom left of the screen on an IBM
compat. or by using the button in the top right hand corner of the screen on a MAC.
Click on the screen shot you want and then go to the Edit menu and select Copy.
Return to MS Word and go to the Edit menu and choose Paste.
To position the screen shot
When the screen shot is pasted into MS Word it comes in ‘floating over the text’. This
means that you can pick it up and place it where ever you want.
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To help you out with placement,
a wrapping command exists. To
change the wrapping setting,
click once on the screen shot, go
to the Format menu and select
Picture. The following dialogue
box will appear. Click on the
Wrapping tab and set the type
of text wrapping you desire.
I find the Tight – Both sides
setting useful if I want the screen
shot at the side of the page and
the Top & bottom setting good
if I want to have the screen shoot
breaking up the text.
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Transferring one list of data from MS Excel to the CFX-9850GB PLUS
Leave the FA-123 program running (it may pay to close MS Word). Start MS Excel
and have one column of data (numeric data only) entered (or other data you already
have collected.

Go to the File menu and choose Save As. Select the position you wish to save to as
you normally would (choose to save it on the desktop in this case). Choose the file
type of CSV and name of the file as you desire, I have chosen Test 1.

Now go to the FA-123 program and select CSV and then Load from CSV from the
file menu.

Locate the .csv file that you saved to the desktop. On an IBM compatible choose
c:\windows\desktop and you will locate it. Be sure to have the List button chosen.
You can choose a List number here also, it will be the list into which the data will go
in the calculator.
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Click OK and the data will be transferred to a list in Casio form.

Now save this file from within the FA-123 program as you would normally, but be
sure to check the correct calculator type (fx7400/CFX-9850 series).

If you are using a MAC attach the suffix .cat to the file name so it can be transferred
to an IBM compatible. The suffix is added automatically on an IBM compatible.
Now turn your calculator on and have it connected to the computer. Ensure you have
no data in the list menu you want to keep. If you do select a different file on the
calculator. To do this, enter the List (4) mode and from within Set-Up
(Shift then MENU) select an appropriate file.

Select LINK (D) from the MAIN MENU. Then select Receive (F2). The
calculator is now ready to receive the data.
Go back to the computer and open the .cat file that contains the data you wish to
transfer into the calculator. Highlight the list you want to transfer

Go to Link menu and select Transmit. The data will be transmitted to the
corresponding list in your calculator.
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Transferring multiple lists of data from MS Excel to the CFX-9850GB
PLUS
Add a second list of data to the spreadsheet you were using.
Follow all the instructions for transferring one list until you load the .csv file into the
FA-123 program. Do the following from there on. In this case a whole file will be
transferred to your calculator rather than just one list.
Locate the .csv file that you saved to the desktop. On an IBM compatible choose
c:\windows\desktop and you will locate it. Be sure to have the List File button chosen.
You can choose a File number here also, it will be the list into which the data will go
in the calculator.

Click OK and the data will be transferred to a list in Casio form. Note there is now
two lists here.

Now save this file from within the FA-123 program as you would normally, but be
sure to check the correct calculator type (fx7400/CFX-9850 series).
If you are using a MAC attach the suffix .cat to the file name so it can be transferred
to an IBM compatible. The suffix is added automatically on an IBM compatible.
Now turn your calculator on and have it connected to the computer.
Select LINK (D) from the MAIN MENU. Then select Receive (F2). The
calculator is now ready to receive the data.
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Go back to the computer and open the .cat file that contains the data you wish to
transfer into the calculator. Highlight the file you want to transfer.

Got to Link menu and select Transmit. The file will be transmitted to the
corresponding file in your calculator.
Transferring multiple lists of data from the CFX-9850GB PLUS to MS
Excel.
This is an especially useful feature if you wish to collect data from the data logger and
transfer it to MS Excel for analysis and publication.
Have two lists of data in the lists of your calculator.
Identify what file you are working in (go to the List
mode and access SET UP)

Have the calculator connected to the computer and have the Fa-123 program running
on the computer. Go to the Link menu and choose Receive.
From the Main Menu enter the LINK (D) mode.
Choose to Transmit (F1)

Choose Select (F1) and then use the down arrow keys to find the current File,
File 2 in my case and then use SEL (F1) to select them. The little arrow will tell
you that they are selected.
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Then use TRAN (F6) to transmit the files. Choose Yes (F1) when asked if it is
OK to transmit.

On the computer you should see the following, note that all of the lists in the file are
transferred:

You can save this data as a .cat file at this stage for safe keeping and transferring back
to the calculator and other calculators at a later date. Go to the File menu and then
Save As. Save as you normally would, if you are using a MAC attach the suffix .cat to
the file name so it can be transferred to an IBM compatible. The suffix is added
automatically on an IBM compatible.
To allow this data to be opened in MS Excel you can now save this file as a CSV file
as follows:
Go to the File menu and choose CSV and then Save as CSV. You will not be able
to give this file a name, just a location. In my case it will be called File2.csv.

Now go to MS Excel, go to the File menu and choose Open. Locate the file called
File2.csv or whatever it will be in your case. Click OK and the data should appear in
MS Excel. The data will be in scientific notation, simply highlight it and go to the
Format menu and select Cells…, proceed from there.
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Transferring .CAT files into and out of the CFX-9850GB PLUS
.cat files are computer files that contain data or programs that the calculator can use.
They can be stored on a computer for safe-keeping.
Start the FA-123 program and open the .cat file that you want to transfer. Highlight
the thing you want to transfer.

On your calculator enter LINK mode and select Receive (F2).
Then in the FA-123 program go to the LINK menu and choose Transmit. You should
be done.
Programs that are saved as .cat files can be transferred in the same way.
To transfer the .cat files from the calculator to the computer simply select Transmit on
the calculator, select what you want to transfer and then choose to Receive from
within the FA-123 program.
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Transferring data and programs from CFX-9850GB PLUS to another

CFX-9850GB PLUS
Once you have one calculator set up with the data and or programs that have been
transferred to it from a computer or that you have manually entered and you want to
transfer this to other calculators proceed as follows:
Connect two calculators together with a SB-62 cable (the little one with two ear phone
jacks attached at either end).
On the calculator that you want to receive the data enter
LINK mode and select Receive (F2). It will then be in
receiving mode.

On the calculator that you have the items you want to
share data enter LINK mode and select Transmit (F2).
Then select what you want to transmit using SEL (F1).
I have chosen to transmit a program called SPSD.EXE,
a matrix MAT A and List 1 and List 2 data.
Use TRAN (F6) to transfer these items. Choose Yes (F1) when asked if it is OK
to transmit.

Transferring the complete contents of one to another
If you want to transfer the complete contents of one calculator to another, instead of
choosing SEL (F1) to select what to transmit, choose BACK (F6), which stands for
Backup.

The complete contents of the calculator will be transferred to the other one.
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Transferring to lots of calculators.
If you have lots of calculators to transfer a set of data or programs to, instead of
choosing SEL (F1) repeatedly, do this once and then when hooked up to the next
calculator choose CRNT (F2), see above screen capture, and you will be able to
transmit the current selection – this saves time.
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